Issues with downloading the latest version (2.1.1) and mapping the reference data

I’ve tried both downloading through bioconda via the latest version line of code and the specific version line of code, indicating v.2.1.1. When I install via the latest version (environment name gtdbtk), the list of new packages to be installed indicate that gtdbtk v1.0.2 is the version I am getting. However, when I install specifying v.2.1.1, there is no /etc/conda/activate.d/ within the gtdbtk-2.1.1 environment, so I am unable to edit the file path for the reference data. The /etc/conda/activate.d/ does exist in the gtdbtk environment, but again, that downloaded v1.0.2, NOT the latest version like it was supposed to. Any idea on how to resolve this?

Thanks for your feedback,
we are aware of the issue during the installation of GTDB-Tk. It seems that conda is pointing by default to v1.0.2 ( because this is the only linux specific build).
We are currently working on a solution to facilitate the install.

In the meantime you can try to automatically alias GTDBTK_DATA_PATH whenever the environment is activated by setting environment-specific variables, e.g.:

# Activate the GTDB-Tk conda environment
conda activate gtdbtk-2.1.1

# Set the environment variable to the directory containing the GTDB-Tk reference data
conda env config vars set GTDBTK_DATA_PATH="/path/to/unarchived/gtdbtk/data";